SyntaxHighlighter Evolvedが機能しない!その対処法

wordpressでブログを書き始めて、コーディングネタなどを書いていると、読者の方にわかりやすいようにコードに色付けなどしたくなります。

そこで、wordpressのプラグインのSyntaxHighlighter Evolvedを導入してみたのですが、なぜか機能しません。
ちゃんと[]でくくってコードを記述しているのに、まったく表示したコードがSyntaxHighlighterに変換されません。
[js][/js]や[html][/html]や[css][/css]でコードを囲っているのに、なぜだろう?

そこで調べてみると、結構簡単に解決しました。
footer.phpファイルのbodyタグの閉じタグ</body>の直前に下記を記述します。

<?php wp_footer(); ?>

wordpress.orgのSyntaxHighlighter EvolvedのFAQに注意書きがありました。

●SyntaxHighlighter EvolvedのFAQ
https://wordpress.org/plugins/syntaxhighlighter/faq/

テーマを自作したりするとついつい<?php wp_footer(); ?>って忘れてしまいます。
<?php wp_head(); ?>や<?php wp_footer(); ?>がないとwordpressでプラグインが動作しないなどの不具合が起こりやすいということなので忘れないようにしないといけないですね。